Hotel Reservation System Requirements Print E-mail
Written by Bug Software LLC   
Friday, 17 August 2007

The server performance, recommended for BugHotel Reservation System to be run on, depends on the number of visitors your site will have. For best results and compatibility, we recommend using PHP/MySQL/Apache Server on a Unix based platform. If you have any questions about server setup or installation, please contact us.

A web server with support for PHP version 4.0.6 or better.
Tested using Apache version 1.3, Apache version 2.x and IIS version 6.

A database supported by ADOdb Database Abstraction Library
Tested very well using MySQL, PostGreSQL & Microsoft SQL server. Althought not tested, BugHotel Reservation System should also work with Microsoft Access, DB2, Oracle, iBase, FireBird, MaxSQL, SAPdb and others.

PHP 4.X (Zend Engine) or higher. PHP 5.x is supported.
PHP is a widely-used general-purpose scripting language that is especially suited for Web development.

Zend Optimizer 3.0 or higher
The Zend Optimizer is a free application that runs the files encoded by the Zend Encoder and Zend SafeGuard Suite, while enhancing the running speed of PHP applications. If your web hosting provider doesn't have Zend Optimizer installed or you don't wish to install Zend Optimizer, contact us and we will install a version of BugHotel Reservation System that doesn't requrie Zend Optimizer.

ionCube
If your hosting service provider doesn't have Zend Optimizer Version 3.0 or higher installed you can still run BugHotel Reservation System, we can provide you with BugHotel Reservation System ionCube Version that doesn't require Zend Optimzier Version 3.0 or higher to be installed. BugHotel Reservation System ionCube Version is available to Licensed Users and it can be downloaded from the Downloads section.

PHPPHP Settings
Make sure the following directive/settings are correctly set:

allow_url_fopen = On Fopen wrappers need to be enabled by default (This setting can only be set in php.ini due to security reasons). Althought this is not mandatory and BugHotel Reservation System will work with Fopen wrappers disabled, property images and images in general may not display correctly.

file_uploads = On Whether or not to allow HTTP file uploads. (This setting can only be set in php.ini due to security reasons). Althought this is not mandatory and BugHotel Reservation System will work with File Uploads disabled, property images and images in general can't be uploaded via control panel interfaces (Hotelier, Travel Portal, etc...).

PHP Extensions
BugHotel Reservation System requires or makes use of following extensions:

PCRE Regular Expression Functions (Perl-Compatible) Regular Expression Functions extension is required to install BugHotel Reservation System. Beginning with PHP 4.2.0 these functions are enabled by default. The windows version of PHP has built in support for this extension. This extension is not available only if disabled by the administrator else it's enabled by default. More informations available @ http://us2.php.net/pcre

XML Parser Functions XML (eXtensible Markup Language) extension is required to install BugHotel Reservation System. These functions are enabled by default, using the bundled expat library and has no configuration directives defined in php.ini. This extension is not available only if disabled by the administrator else it's enabled by default. More informations available @ http://us2.php.net/manual/en/ref.xml.php

 

The above requirements are usually met by all web hosting service providers. You can contact your provider for more details.If you don't contact us and we will provide you references.
Last Updated ( Friday, 14 December 2007 )